HP ALM 11.00 and HP Quality Center Enterprise 11.00 – Product Availability Matrix

SYSTEM REQUIREMENTS:
This page provides our recommended and supported environments for HP ALM and HP Quality Center Enterprise version 11.00 and HP Quality Center Premier and HP Quality Center Enterprise version 10.00. The environments list the minimum patch level required for support.

Server-Side System Requirements:
Following are the server system configurations for installing HP ALM 11.00 and HP Quality Center Enterprise 11.00 on Windows, Linux, and Solaris.

Note that these requirements do not apply if you are utilizing Managed Software Solutions for HP ALM or HP Quality Center Enterprise. In that case, the Managed Software Solutions team provides a hosted version of HP ALM or HP Quality Center Enterprise, so the only requirements are the Client-Side System Requirements listed below.

Hardware Minimum Requirements:

CPU Windows: Quad Core AMD64 processor or equivalent x86-compatible processor
Linux: Quad Core AMD64 processor or equivalent x86-compatible processor
Solaris: SPARC architecture required (x86 architecture is NOT supported)
Memory (RAM) 4 GB minimum
Free disk space 8 GB minimum

Recommended Environments:
The following table includes recommended configurations for each operating system.

Operating System

App Server DB Server Web Server
Win2008 SP2 64bit
JBOSS 5.1 SQL 2008 SP1 JBOSS 5.1
Sun Solaris 10 64bit
WebLogic 10.3 Oracle 10.2.0.4 Apache 2.2
Linux Red Hat 5.4 64bit
WebLogic 10.3 Oracle 10.2.0.4 Apache 2.2
HP-UX 11.31 v3 64bit (Itanium)
JBOSS 5.1 Oracle 10.2.0.4 JBOSS 5.1

Supported Environments:
The following tables include supported versions of Operating Systems, Application Servers, Database Servers, and Web Servers.

Operating System Requires HP Patch
Windows Server 2003 SP2 (32 and 64 bit) Windows Server 2003 R2 SP2 (32 and 64 bit)

Windows Server 2008 SP2 (64 bit)

Windows Server 2008 R2 (64 bit) Windows Server 2008 R2 SP1 (64 bit) Patch 2 required for Windows Server 2008 R2
Patch 6 required for Windows Server 2008 R2 SP1
Sun Solaris 10 (64 bit)
Linux Red Hat 5.4 (64 bit)
Linux Red Hat 5.6 (64 bit) Patch 6 required for Linux Red Hat 5.6
HP-UX 11.31 v3 (64 bit Itanium)
Linux SUSE 10 (64 bit) Linux SUSE 10 SP4 (64 bit) SP3 required for Linux SUSE 10 SP4
Oracle Linux 5.4 (64 bit)
Oracle Linux 5.6 (64 bit) Patch 6 required for Oracle Linux 5.6

NOTE: For large production deployments it is recommended that ALM/QC be deployed on 64 bit systems.

Application Servers
Supports 64bit JVM***
Requires HP Patch
JBOSS 5.1
Yes
WebLogic 10.3 and higher dot releases*
Yes
WebSphere 7.0.0.9 and higher dot releases**
Yes

NOTES:
- Both standard and enterprise editions of WebLogic are supported as long as there are no infrastructure changes with each dot release.
- WebSphere dot releases supported as long as there are no infrastructure changes with those.
- ALM/QC 11 supports application servers which run JDK6 and 64 bit JVM.

Database Servers Requires HP Patch

Oracle 10.2.0.4

Oracle 11.2.0.1 Oracle 11.2.0.2 Oracle 11.2.0.2 Requires Patch 6
SQL 2005 SP3 SQL 2005 SP4 SQL 2008 SP1 SQL 2008 SP2 SQL 2008 R2 SP1 SQL 2008 SP2 Requires Patch 6
SQL 2008 R2 SP1 Requires SP2
SQL 2005 SP4 Requires SP3

NOTE: All database servers, unless otherwise stated, have been validated on 64 bit configurations.

Web Servers Requires HP Patch
Apache 2.2
IIS6 IIS7 IIS 7.5 IIS 7.5 Requires Patch 6
IHS Server

NOTE: By default application servers include HTTP servers. If you need additional functionality a web server can be added.

Virtual Environments Requires HP Patch
VMware ESX 4.0 Patch 1
VMware ESX 4.1 Patch 6
Citrix XenApp 6.0

Server System Configurations for Starter Edition:
This section describes the server system configurations for installing a Quality Center Starter Edition server.

Operating System

Database Server Application and Web Server
Windows XP (SP3)
Windows Server 2008 (SP2)
Microsoft SQL Server 2005 SP2 Express edition installed during the installation process
NOTE: Installed during the installation process. If SQL Server 2005 or 2008 is already installed on the server machine, you can instruct Quality Center to use it, by providing the administrator name and password.
JBoss

NOTE: Installed during the installation process.

NOTE: For prerequisites and client side requirements for QC Starter 11 clients refer below.

Client-Side System Requirements:
This section describes the client system configurations for installing an HP ALM or HP Quality Center Enterprise client or QC Starter Edition 11 clients.

CPU

Core duo 1.6 Ghz (or higher) or equivalent compatible processor
Memory (RAM)
2 GB minimum
Free disk space 2 GB minimum
Prerequisites
  • Visual C++ 2005 SP1 ATL Security Update Redistributable
  • Microsoft .NET Framework 3.5 (SP1)
  • Microsoft Office 2007 (SP2) (recommended)
Operating System
  • Windows XP (SP3) 32 bit
  • Window Vista (SP1) 32 bit
  • Window Vista (SP2) 32 bit, requires patch 6
  • Windows 7 32 bit (recommended)
  • Windows 7 64 bit, requires patch 2
  • Windows 7 (SP1) 64 bit, requires patch 6
  • Windows 2008 R2 requires patch 1
  • Windows 2008 R2 SP1 requires patch SP3 ( Do NOT use BPT as it is not certified for this)
  • Windows 2003 SP2 requires patch 3
  • Windows Server 2008 SP2 32 bit, requires patch SP2

NOTES:
If you are integrating Quality Center with other HP testing tools, you must modify the DCOM permissions on your client machine.
ALM/QC Client on Windows 7 64 bit runs in WOW64 mode (details in patch 2 Readme file).
You can work with the Quality Center client using a remote desktop

Virtual Environments Certified to run on Citrix XenApp 6.0. Citrix Client with XenApp 6.0: Online Plug-In 12.1.

Also certified to run on VMware ESX 4.0 ( Patch 1) and VMware ESX 4.1 (Patch 6)
VMware ESX 5.0 and ESXi 5.0 (SP3)

Browser Microsoft Internet Explorer 7 or 8
Microsoft Internet Explorer 9 (requires SP2)

NOTE: For customers who have restrictions on plugins in their browsers, such as ActiveX, ALM can be loaded in the HP ALM Explorer Add-in. For more information on downloading and installing the add-in, refer to the HP Application Lifecycle Management Installation Guide.

Office Compatibility Microsoft Office 2007 SP2 (recommended)
Microsoft Office 2010 (requires Patch 3)
NOTE: Only 32 bit versions of MS Office supported

NOTE: Supported resolution is 1024×768 with DPI of 100%.

DA-14061 9 – Version 9 – June 29, 2012